tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kirk True <>
Subject Minor changes needed to compile trunk and import into Eclipse
Date Mon, 07 Jan 2008 04:36:49 GMT

Hi all,

I downloaded the source for the trunk and tried to compile it, but ran into
some minor issues...

The first problem is that "ant download" couldn't compile some dependencies
because I was using Java 1.6. I assumed this was OK as the verbiage states
something to the effect of Java 5 or greater. I installed the latest Java 5,
updated my JAVA_HOME variable, and "ant download" and "ant" worked fine. Is
1.6 expected to work?

Secondly, (even though I know it's "unsupported") I imported the stock
.project into my Eclipse workspace.
I had three minor issues: 

    1. org/apache/naming/factory/webservices isn't excluded in the
.classpath file as it is
        in the build.xml
    2. The Eclipse plugin has been updated, so the downloaded dependency was
        while the .classpath expected 3.1.2
    3. The Ant JAR dependency was not downloaded, so I updated the
.classpath to use

diff of .classpath:

Index: .classpath
--- .classpath  (revision 609508)
+++ .classpath  (working copy)
@@ -16,10 +16,10 @@
   limitations under the License.
-       <classpathentry
excluding="**/.svn/**|org/apache/tomcat/util/net/puretls/" kind="src"
+       <classpathentry
kind="src" path="java"/>
        <classpathentry kind="src" path="webapps/examples/WEB-INF/classes"/>
        <classpathentry kind="con"
-       <classpathentry kind="var"
-       <classpathentry kind="var"
+       <classpathentry kind="var" path="ANT_HOME/lib/ant.jar"/>
+       <classpathentry kind="var"
        <classpathentry kind="output" path=".settings/output"/>

View this message in context:
Sent from the Tomcat - Dev mailing list archive at

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message