tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44094] New: - privileged="true" causes ClassNotFound from shared\lib
Date Tue, 18 Dec 2007 18:54:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=44094>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=44094

           Summary: privileged="true" causes ClassNotFound from shared\lib
           Product: Tomcat 5
           Version: 5.5.17
          Platform: PC
        OS/Version: Windows Server 2003
            Status: UNCONFIRMED
          Severity: normal
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: jdeardurff@ntst.com
                CC: jdeardurff@ntst.com


By adding the privileged="true" attribute to the Context element of some
conf\Catalina\localhost\myApp.xml as in:

<Context path="/myApp" docBase="C:/myApp/" cookies="false" override="true"
privileged="true">

Jar files within shared\lib are no longer loaded for the myApp application, but
jars from common\lib are. 

We are using Tomcat 5.5.17 with JRE 5.5_06 running on Windows and AIX servers.
The problem is consistently reproducible. 

For us the temporary workaround has been to move our shared jars from shared\lib
to common\lib.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message