tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43759] New: - setclasspath.sh does not set the CLASSPATH for system classloader
Date Wed, 31 Oct 2007 19:13:01 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43759>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43759

           Summary: setclasspath.sh does not set the CLASSPATH for system
                    classloader
           Product: Tomcat 5
           Version: Unknown
          Platform: Sun
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: vadim.marchenko@gmail.com


setclasspath.sh does not actually export variables such as CLASSPATH for example.
As a result tools.jar is not in the classpath and when tomcat starts up it reports
org.apache.jasper.JasperException: Unable to compile class for JSP

Most people have found a workaround but copying tools.jar to the common/lib.

Appending to the script statement like
export CLASSPATH
solves the problem.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message