tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Tomcat Wiki] Update of "TomcatVersions" by markt
Date Fri, 05 Oct 2007 01:44:32 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Tomcat Wiki" for change notification.

The following page has been changed by markt:
http://wiki.apache.org/tomcat/TomcatVersions

------------------------------------------------------------------------------
  = Draft =
  Need to resolve TBDs. Specifically:
   * Do we want to continue to provide support (currently only security fixes) for 3.3.x?
+    * markt: Suggest we drop all support for 3.x
   * If yes, who is release manager for 3.3.x?
   * If no, do we want to remove 3.3.x from the main download page?
+    * markt: Yes, if it is agreed to drop support for it
   * Do we want to continue to provide support (currently only security fixes) for 5.0.x?
+    * markt: Suggest we drop support for 5.0.x
   * If yes, who is release manager for 5.0.x?
   * If no, do we want to remove 5.0.x from the main download page?
+    * markt: Yes, if it is agreed to drop support for it
   * What level of support do we want to provide for 5.5.x?
+    * markt: Bug fixes and security fixes, no enhancements
   * Once we have a stable release of 6.2.x, what support do we want to provide for 6.0.x?
+    * markt: None. The API change is likely to be minor and impact zero to very few users.
If it is an issue then we can change our minds and limit it to just security fixes.
   * What features/API changes do we want to include in 6.2.x
     * remm: It could be limited to the AnnotationProcessor -> InstanceManager replacement,
and have the branch simply take over for 6.0.x immediately. This also allows placing 6.0.x
in security fixes mode since 6.2 is a trivial upgrade path.
+    * markt: I'd go further and not do any updates for 6.0.x
   * What features/API changes do we want to put in 6.3.x for future inclusion in 6.4.x and/or
7.0.x?
+    * markt: That is what the STATUS file and voting is for ;)
  
  = Tomcat 3.0.x to 3.2.x =
  ||Spec versions:||Servlet 2.2, JSP 1.1||

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message