tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 42976] New: - Certain valid Content-Type headers are messed up before sending on the wire.
Date Thu, 26 Jul 2007 01:32:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=42976>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=42976

           Summary: Certain valid Content-Type headers are messed up before
                    sending on the wire.
           Product: Tomcat 6
           Version: 6.0.11
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: dan@kulp.com


(this bug exists in Tomcat 5.5.23 as well)

For some SOAP/Mime stuff, we're trying to set a Content-Type of:

multipart/related; type="application/xop+xml"; 
boundary="----=_Part_0_2147172487.1185331898894"; 
start="<root.message@cxf.apache.org>"; start-info="text/xml;charset=UTF-8"

(that should all be on one line)
However, tomcat is screwing it up and removing the final double quote.   It 
looks like tomcat is just searching for charset= without regards to the 
context it might be used in.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message