tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 42147] New: - mod_jk: JkLogLevel set to error, however apparently logging at info
Date Tue, 17 Apr 2007 14:31:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=42147>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=42147

           Summary: mod_jk: JkLogLevel set to error, however apparently
                    logging at info
           Product: Tomcat 6
           Version: unspecified
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: major
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: nblair@doit.wisc.edu


I apologize if this is reported in the wrong location; I could not find a
product associated with just the Tomcat Connector product (mod_jk).

I am using mod_jk 1.2.21 on Solaris 8 with Apache 2.0.59. During regular
maintenance I noticed that our mod_jk.log had grown far larger than expected.
It is filled with lines like the following:

[Tue Apr 17 09:26:19 2007] worker server.wisc.edu 0.008697
[Tue Apr 17 09:26:21 2007] worker server.wisc.edu 0.014478
[Tue Apr 17 09:26:21 2007] worker server.wisc.edu 0.004808
[Tue Apr 17 09:26:21 2007] worker server.wisc.edu 0.008812
[Tue Apr 17 09:26:21 2007] worker server.wisc.edu 0.009066

I thought that these lines were only output at the "info" JkLogLevel, however
the server is currently configured at the "error" JkLogLevel.

Here is my relevant connector configuration in apache:
LoadModule jk_module modules/mod_jk.so
JkWorkersFile /path/to/httpd/conf/workers.properties
JkLogFile /path/to/httpd/logs/mod_jk.log
JkLogLevel error
JkLogStampFormat "[%a %b %d %H:%M:%S %Y] "
JkRequestLogFormat "%w %V %T"

workers.properties looks like:
worker.list=worker
worker.worker.type=ajp13
worker.worker.host=127.0.0.1
worker.worker.port=8009

Is it possible these log statements are incorrectly being made at the error
level, or is this desired behavior?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message