tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41746] New: - Default web application can not be changed
Date Fri, 02 Mar 2007 13:03:39 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41746>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41746

           Summary: Default web application can not be changed
           Product: Tomcat 6
           Version: unspecified
          Platform: PC
        OS/Version: Mac OS X 10.4
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: smarjan@keenresearch.com


I have downloaded tomcat 6.0.10. 
I added mysql-connector, log4j and commons-logging to lib directory.
My context.xml file, located in META-INF directory looks like this:
<Context path="" debug="5" reloadable="true" crossContext="true" docBase="lootist">
  <Manager className="org.apache.catalina.session.PersistentManager"
saveOnRestart="false"/>
  <Resource name="jdbc/lootist" auth="Container" type="javax.sql.DataSource"
               maxActive="15" maxIdle="5" maxWait="19000" scope="Shareable"
               username="lootist" password="lootist"
driverClassName="com.mysql.jdbc.Driver"
               url="jdbc:mysql://localhost:3306/lootist?autoReconnect=true" />

  <Resource name="repository/lootist" auth="Container"
type="com.lootist.webapp.beans.context.Repository"
               scope="Shareable" factory="org.apache.naming.factory.BeanFactory"
               productImageLocation="/lootist/data/repository/productimages"
              
productSecondaryImageLocation="/lootist/data/repository/productsecondaryimages"
               lootistImageLocation="/lootist/data/repository/lootistimages"
                />

</Context>

When I deploy it on tomcat, the default web application is still ROOT webapp. 
There are no warning/error messages (in all logs, including my application log)
except these:

Catalina.out:
Mar 2, 2007 1:51:21 PM org.apache.catalina.session.PersistentManagerBase start
SEVERE: No Store configured, persistence disabled
Mar 2, 2007 1:51:25 PM org.apache.catalina.startup.HostConfig deployDescriptor
WARNING: A docBase /Volumes/Work/apache-tomcat-6.0.10/webapps/lootist inside the
host appBase has been specified, and will be ignored

I haven't changed anything in tomcat config and I haven't deployed any other apps. 

Note:
I tested the same app. couple of weeks ago on Apache Tomcat 6.0.7 and everything
worked ok.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message