tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41740] New: - Environment tags not being picked-up in DefaultContext
Date Thu, 01 Mar 2007 16:26:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41740>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41740

           Summary: Environment tags not being picked-up in DefaultContext
           Product: Tomcat 5
           Version: 5.5.20
          Platform: All
        OS/Version: other
            Status: NEW
          Severity: regression
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: ben.dilley@skillstream.co.uk


I'm running tomcat 5.5.20 and I'm unable to retrieve Environment variables that
are defined in the DefaultContext. I know this isn't working because if I alter
the DefaultContext tag to a Context one and run the same webapp, the Environment
variables are retrieved successfully by the app.

This is a problem because multiple auto-deployed apps need to share the same
Environment variables. The only available workaround is to repeat the
Environment tags within explicit Context tags for each known webapp deployed in
the Host's appBase.

This has been tested in Linux using jdk 1.6 and in Windows using jdk 1.5.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message