tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41739] New: - The servlet with the value 0 in <load-on-startup> tag must be loaded at first.
Date Thu, 01 Mar 2007 14:09:41 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41739>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41739

           Summary: The servlet with the value 0 in <load-on-startup> tag
                    must be loaded at first.
           Product: Tomcat 5
           Version: 5.5.20
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: suzuki.yuichiro@jp.fujitsu.com


Servlet 2.4 specification says:
---
If the value is a positive integer or 0, the container must load
and initialize the servlet as the application is deployed. 
The container must guarantee that servlets marked with lower integers
are loaded before servlets marked with higher integers.
---
I think the servlet with value 0 in <load-on-startup> tag must be loaded at the 
first.

However, Tomcat loads the servlet at the last.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message