tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41535] New: - IIS 6+JK 1.2.0+Tomcat 5.5.20 web app FORM based auth hangs
Date Sun, 04 Feb 2007 04:50:51 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41535>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41535

           Summary: IIS 6+JK 1.2.0+Tomcat 5.5.20 web app FORM based auth
                    hangs
           Product: Tomcat 5
           Version: 5.5.20
          Platform: Other
        OS/Version: Windows XP
            Status: NEW
          Severity: major
          Priority: P2
         Component: Native:JK
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: jasona@blazetrail.ca


When attempting to use FORM based authentication from a web app running in 
Tomcat 5.5.20 (JBoss 4.0.5GA), with JK 1.2.0 via ajp13 (localhost) and IIS 6, 
the form submit via POST hangs.

All other content via the isapi_redirect.dll works just fine.  Also, if you 
change the login.jsp to GET method, it works.  Seems to be problem with just 
POST.

redirect log reports:

[Sat Feb 03 21:31:40 2007] [24540:19136] [error] jk_isapi_plugin.c (624): 
ReadClient failed with 0000274c
[Sat Feb 03 21:31:40 2007] [24540:19136] [info]  jk_ajp_common.c (1110): () 
receiving data from client failed. Connection aborted or network problems
[Sat Feb 03 21:31:40 2007] [24540:19136] [info]  jk_ajp_common.c (1893): 
(ajp13w) sending request to tomcat failed, because of client read error without 
recovery in send loop attempt=0
[Sat Feb 03 21:31:40 2007] [24540:19136] [debug] jk_isapi_plugin.c (1093): 
service() returned OK
[Sat Feb 03 21:31:40 2007] [24540:19136] [debug] jk_ajp_common.c (2229): will 
be shutting down socket 1336 for worker ajp13w



Incomplete POST gets to Tomcat, as Tomcat reports:

2007-02-03 21:30:40,349 DEBUG [org.apache.catalina.connector.CoyoteAdapter]  
Requested cookie session id is CEEA5F00E90E6F3A63C44E81609E6CBB
2007-02-03 21:30:40,349 DEBUG 
[org.apache.catalina.authenticator.AuthenticatorBase] Security checking request 
POST /iffl/tims/content/j_security_check
2007-02-03 21:30:40,365 DEBUG [org.apache.jk.common.JkInputStream] doRead false 
0 0
2007-02-03 21:30:40,365 DEBUG [org.apache.jk.common.ChannelSocket] receive() 
...
2007-02-03 21:31:40,351 INFO  [org.apache.jk.common.JkInputStream] Receiving: 
getting request body chunk -3 4
2007-02-03 21:31:40,351 DEBUG 
[org.apache.catalina.authenticator.FormAuthenticator] Authenticating 
username 'null'

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message