tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41533] New: - ISAPI Redirector fails silently if init_ws_service or get endpoint fails
Date Fri, 02 Feb 2007 23:07:07 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41533>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41533

           Summary: ISAPI Redirector fails silently if init_ws_service or
                    get endpoint fails
           Product: Tomcat 5
           Version: 5.0.0
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P3
         Component: Native:JK
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: Tim.Whittington@orionhealth.com


If the init_ws_service or worker->get_endpoint in HttpExtensionProc fails, then
the Extension exits silently (with an error code).
The result for the user agent is a 500 error, with no indication in the logs
that an error occurred within the redirector.

On the other hand, if a worker can't be obtained, an error is logged, which is
inconsistent.

I'll attach a patch that logs these failures as errors (+ a couple of incidental
changes to logging for consistency).

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message