tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41577] - images under ssl fail to load
Date Mon, 12 Feb 2007 22:13:06 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41577>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41577





------- Additional Comments From rvann@auctio.com  2007-02-12 14:13 -------
(In reply to comment #4)
> Clear all your browser caches and try again, does that solve the problem.
> if it works in one browser but not the other, then it sounds like a browser 
bug
> rather than Tomcat.
> Please upload a simple test WAR, so that we can try to reproduce it.
> If we don't hear from you in a week, will close this bug down.
> best regards

There is no need to create a war file - all you have to do is plop a couple of 
images in the ROOT directory of tomcat and create a simple html file with a 
couple of IMG tags referencing these images and it will fail if you use the 
nio protocol under SSL.  This will happen with a new install of Tomcat6.09 and 
ie 6 with all caches empty and everything set to default settings.  From what 
I have been able to determine from researching this in various places - this 
behavior is attributed to an ie "bug".  While this problem may manifest as a 
result of an ie bug, that is irrelevant because this issue affects anyone 
using ie who attempts access this type of application - seems to me to be a 
show stopper limitation of Tomcat.  I certainly can't use a Tomcat version 
beyond 4.1 until this is fixed in Tomcat, because I can't expect my customers 
to abandon using ie for Firefox.  Which is too bad because I have a killer 
application that could take advantage of the advanced i/o features of Tomcat6.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message