tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "William L. Thomson Jr." <wl...@gentoo.org>
Subject Re: Building the Jasper compiler
Date Mon, 12 Feb 2007 22:27:01 GMT
On Mon, 2007-02-12 at 14:04 -0800, M Coffee wrote:
>
> There is a jasper build.xml, but it doesn't build the jars without a
> complete Tomcat build environment (and possibly an older version of
> Ant), so I stopped working on debugging that one. There's no
> documentation for it either -- the code is the documentation, I guess.

Ok, so that means 5.x, ideally 5.5.x. We were building 5.0.28's jasper
with no modifications that I can see. Here is our ebuild for
tomcat-jasper-5.0.28.

http://overlays.gentoo.org/svn/proj/java/migrated-java-experimental-overlay/dev-java/tomcat-jasper/tomcat-jasper-5.0.28.ebuild

It's basically a custom bash script ( Gentoo specific ) which is what we
call a "package". It just unpacks, set's up the env, propererties and
etc, then invokes ant, and installs the stuff once done. No patches or
etc are applied to sources, so we are just invoking the shipped
build.xml for jasper.

Off hand I can't see where 5.5.x would be much different, since 5.0.x
and 5.5.x have similar build systems for the most part. Devs are welcome
to correct me there if I am missing something. It's been a very long
time since I messed with 5.0.x sources ;) A few months since last with
5.5.x.

> I definitely don't want to move up to Tomcat 6 until the problems with
> debugging JSP pages in the Tomcat 5 environment are resolved.  We've
> waited a while, and now I'm trying to hack it to the point where we
> can use it internally.

Er, I would focus on 6.0.x. If your still on 4.x, why even bother with
5.x? I would start testing 6.0.x, since it's pretty different than 5.x.
If you must with 5.x, then 5.5.x.

-- 
William L. Thomson Jr.
Gentoo/Java

Mime
View raw message