tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mladen Turk <mt...@apache.org>
Subject Re: tcnative 1.1.8 -- offically released as stable?
Date Wed, 03 Jan 2007 21:40:47 GMT
Jess Holle wrote:
> Has tcnative 1.1.8 been officially released, i.e. as stable?
> 

There is no vote on tcnative releases. The vote is part
of Tomcat release.

> It seemed like it was going to be from various votes, etc -- but I never 
> saw any form of announcement.
> 
> Given the serious issues in a number of the previous tcnative releases, 
> we've had to disable tcnative.

Tcnative is bound to the Tomcat release.
The major problem is that we have releases as non mandatory.
You will have INFO message in case the tcnative version
is below recommended one. Of course that allows to run the
tcnative versions that have known bugs.
I've tried to enforce that rule, but was over voted :)
Although the API is the same, I really see no reason to
allow tcnative-1.1.5 (or any pre 1.1.8)
running on any further Tomcat release. It would make sense if
this was performance release, but since its mostly bugfix release
having next Tomcat release allowing buggy tcnative versions would
only bring more concerns like yours.

Regards,
Mladen.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message