tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41106] - "deferred" expression fails if <jsp-version> less than 2.0
Date Tue, 05 Dec 2006 14:27:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41106>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41106





------- Additional Comments From stan@jboss.com  2006-12-05 06:27 -------
FYI

The old JSF tags processed the EL themselves.  That's the root of the problem. 
So for an Ajax4JSF tag might look like this:

<a4j:commandButton actionListener="#{mybean.action}"/>

The tag would delegate to JSF 1.1 for processing the EL.  This component still
works in JSF 1.2 but now JSF 1.2 delegates back to the EL impl included in JSP
2.1.  So, the old JSF tags need #{mybean.action} to be passed in as a simple
String instead of a MethodExpression or ValueExpression object.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message