tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41091] New: - Issue with JSF 1.2 validation when using subviews
Date Thu, 30 Nov 2006 21:16:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41091>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41091

           Summary: Issue with JSF 1.2 validation when using subviews
           Product: Tomcat 6
           Version: 6.0.0
          Platform: Other
               URL: http://mdubuc.freeshell.org/hello2.tar
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: martind1111@gmail.com


If an input text component is included in a subview and the validation fails
during page submission, the JSF controller forces the Web application to stay on
the current page (expected behavior), but it does not render the error messages
on that page.

I have a sample application that demonstrates this problem. The source code and
.war file for this application can be accessed by navigating to the following link:
http://mdubuc.freeshell.org/hello2.tar

In this sample application, the user is presented with an input text in the
first page. If the user clicks OK without filling in the input text, the
application should display an error message to report to the user that a value
is required. However, it does not do this. In the catalina.out log file, some
errors are reported:

Nov 30, 2006 8:38:12 PM com.sun.faces.renderkit.html_basic.HtmlBasicRenderer
getForComponent
WARNING: Unable to find component with ID testj_id_1 in view.
Nov 30, 2006 8:38:23 PM com.sun.faces.renderkit.html_basic.HtmlBasicRenderer
getForComponent
WARNING: Unable to find component with ID testj_id_1 in view.
Nov 30, 2006 8:38:28 PM com.sun.faces.renderkit.html_basic.HtmlBasicRenderer
getForComponent
WARNING: Unable to find component with ID testj_id_1 in view.
Nov 30, 2006 8:38:28 PM com.sun.faces.lifecycle.RenderResponsePhase execute
INFO: WARNING: FacesMessage(s) have been enqueued, but may not have been displayed.
sourceId=hello:test:test[severity=(ERROR 2), summary=(hello:test:test:
Validation Error: Value is required.), detail=(hello:test:test: Validation
Error: Value is required.)]

Looks like the controller was not able to find the component. My guess is that
there is an issue with the proper handling of subviews. The same application
without a subview works fine.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message