tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From PC Varma <>
Subject Tomcat (3.x/4.x/5.x/6.x) is not supporting http(1.0/1.1) CONNECT method.
Date Wed, 29 Nov 2006 17:20:47 GMT

Hi All
       Tomcat (3.x/4.x/5.x/6.x) is not supporting http(1.0/1.1) CONNECT method. I dont know
why its not supporting this feature which is offering a robust communication using HTTP1.0/1.1
Proxying concepts for realstreamings like VNC, RDP etc based products. I have been working
with tomcat from last 5 months. I have developed this support(http CONNECT method) and using
in my "Post graduation Project work" its a "Remote Desktop Management project"  and which
is working fine. 
        Now i would like you guys to confirm that 'am i doing right'?.
       Implementation details :-
       Inside coyote package, we have class called HttpProcessor.class. Its resposible for
processing the http request and where we can identify the which type of the http request being
processed. Then i have added a functionality that will parse and handle Http CONNECT method
as if Http Proxy Impl with Basic authentication support.

      Can you guys please confirm this?

Thanks & Regards
PC Varma

Express yourself with gadgets on Windows Live Spaces
To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message