tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Larry Isaacs" <Larry.Isa...@sas.com>
Subject RE: Eclipse WTP and Tomcat 6.0.x ?
Date Tue, 14 Nov 2006 15:22:21 GMT
I haven't had time to look much at Tomcat 6.0.x yet.  The first
step to patch the org.eclipse.jst.server.tomcat.core plug-in
to accept Tomcat 6 as if it were Tomcat 5.5 would be to modify
the verfiyInstall.properties file and remove "common/i18n" from
the list of what it checks for in 5.5.  At that point, the
plug-in will probably accept an Tomcat version 4.0.x or later
as if it was Tomcat 5.5.  You could then try to see if the
rest of the plug-in will work as is using Tomcat 6.0.x as a 5.5
server.  If I get a chance, I'll give this a quick try in the
near future and see what happens.

Cheers,
Larry

P.S. If you are using the SDK version of WTP or use Update to
get the source, it is fairly easy to patch a plug-in.


> -----Original Message-----
> From: Henri Gomez [mailto:henri.gomez@gmail.com] 
> Sent: Tuesday, November 14, 2006 9:58 AM
> To: Tomcat Developers List
> Subject: Re: Eclipse WTP and Tomcat 6.0.x ?
> 
> Larry, how could we lure the current WTP 1.5.2 to use a Tomcat 6.x ?
> 
> 2006/11/14, Larry Isaacs <Larry.Isaacs@sas.com>:
> > Regrettably, my day job didn't allow for much change in WTP 
> from 1.0.x 
> > to 1.5.x, beyond sporadic bug fixing.  I should be able to get much 
> > more done in WTP 2.0, also in the M4 release time frame.
> >
> > Cheers,
> > Larry
> >
> > P.S. As deprecated as Contexts in server.xml is, it's still 
> the only 
> > approach supported across Tomcat versions since 3.x.
> > I'm not sure when this might change for newer Tomcats, 
> since too much 
> > customization unique to individual versions of Tomcat may eat more 
> > cycles than I have available.  It's something I'm keeping my eye on 
> > though.
> >
> > > -----Original Message-----
> > > From: yoavshapira@gmail.com 
> [mailto:yoavshapira@gmail.com] On Behalf 
> > > Of Yoav Shapira
> > > Sent: Tuesday, November 14, 2006 9:32 AM
> > > To: Tomcat Developers List
> > > Cc: Larry Isaacs
> > > Subject: Re: Eclipse WTP and Tomcat 6.0.x ?
> > >
> > > Hi,
> > > Larry, thanks for these efforts.  I've been wondering for a while 
> > > who was maintaining this support, and never got around to 
> checking.  
> > > It's much appreciated, at least by me, but I'm sure by 
> many others 
> > > as well
> > > ;)
> > >
> > > Yoav
> > >
> > > On 11/14/06, Larry Isaacs <Larry.Isaacs@sas.com> wrote:
> > > > Hi Henri,
> > > >
> > > > Probably before the M4 release of WTP 2.0 in early January.
> > > > The Tomcat support in WTP is where my day job has my spare
> > > time going
> > > > these days, what there is of it. :)
> > > >
> > > > Cheers,
> > > > Larry
> > > >
> > > > > -----Original Message-----
> > > > > From: Henri Gomez [mailto:henri.gomez@gmail.com]
> > > > > Sent: Tuesday, November 14, 2006 5:53 AM
> > > > > To: Tomcat Developers List
> > > > > Subject: Eclipse WTP and Tomcat 6.0.x ?
> > > > >
> > > > > Did there is Eclipse WTP developpers around  ?
> > > > >
> > > > > Just in case of, when could we expect WTP to support 
> Tomcat 6.0 
> > > > > (still not the case in WTP 1.5.2).
> > > > >
> > > > > The Definition for a new server runtime environment 
> still miss 
> > > > > TC 6.0 ;(
> > > > >
> > > > >
> > > > > Regards
> > > > >
> > > > >
> > > 
> --------------------------------------------------------------------
> > > > > - To unsubscribe, e-mail: 
> dev-unsubscribe@tomcat.apache.org For 
> > > > > additional commands, e-mail: dev-help@tomcat.apache.org
> > > > >
> > > > >
> > > >
> > > >
> > > 
> --------------------------------------------------------------------
> > > -
> > > > To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org For 
> > > > additional commands, e-mail: dev-help@tomcat.apache.org
> > > >
> > > >
> > >
> >
> > 
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org For 
> > additional commands, e-mail: dev-help@tomcat.apache.org
> >
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org For 
> additional commands, e-mail: dev-help@tomcat.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message