tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yoav Shapira" <yo...@apache.org>
Subject Re: [build]fail message
Date Thu, 26 Oct 2006 11:38:02 GMT
Hi,


On 10/24/06, Sean Qiu <sean.xx.qiu@gmail.com> wrote:
> I have also tried the "ant test".
> It seems that it is based unit test.

I don't use "ant test" and have no time to delve into what it is.  Use
the tester version.

> I find there are only three testing classes and a few testcases.

The tester contains a little more than 100 unit tests, as you can see
from its output when you run it.

> Need any configuration to make the unit test success?

None besides a proper configuration to start with.  Proper meaning
don't put anything in ANT_HOME/lib, on the CLASSPATH environment
variable (though it's ignored anyhow), in JRE_HOME/lib.  Proper
meaning edit build/build.properties.default as build/build.properties
to reflect your environment.  And that's it.

> And what's the difference between "ant run-tester" and "ant test"? Thanks
> again.

See first answer above.

> BTW, when i run "ant test", it will fail for package missing.
> So i add the revelant *jar files from binary into the "javac"'s classpath
> parameter.
> It works, but of course it is the the right way :) Pls correct me.

See first answer above.

Yoav

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message