tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40832] New: - SSL Configuration/Operation
Date Fri, 27 Oct 2006 17:54:53 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40832>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40832

           Summary: SSL Configuration/Operation
           Product: Tomcat 5
           Version: 5.5.17
          Platform: PC
        OS/Version: Windows Server 2003
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: bobd@nevo.com


We have been using Tomcat 5.5.9 running SSL with no apparent problems, we 
recently attempted to upgrade to Tomcat 5.5.17, however, the SSL configuration 
although the same as the 5.5.9, fails to run properly. A URL such as 
http://domain:443/page does work, however, https://domain/page does not, it 
appears to just timeout. Having reverted back (uninstalled and re-installed) to 
the 5.5.9 version, SSL again operates correctly.  The only difference I can 
note is that when installing the 5.5.17 version we did select the native DLL, 
whereas, this was not available for 5.5.9. We did not try 5.5.17 without the 
native DLL. Our connector configuration is as follows (password and company has 
been disguised):
    <Connector
        port="8080"
        minSpareThreads="25"
        connectionTimeout="20000"
        maxSpareThreads="75"
        maxThreads="150"
        maxHttpHeaderSize="8192">
    </Connector>
    <Connector
        port="8009"
        protocol="AJP/1.3">
    </Connector>
    <Connector
        port="443"
        redirectPort="-1"
        scheme="https"
        secure="true"
        keystoreFile="C:\xxxxxxxxxx\WebApplication\SSL\test\.keystore"
        keystorePass="xxxxxxxxx"
        maxSpareThreads="75"
        maxThreads="150"
        keystoreType="JKS"
        algorithm="SunX509"
        minSpareThreads="25"
        clientAuth="false"
        maxHttpHeaderSize="8192"
	sslProtocol="TLS">
    </Connector>

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message