tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Qiu" <sean.xx....@gmail.com>
Subject Re: [build]fail message
Date Tue, 24 Oct 2006 14:54:55 GMT
You are so nice.  :)

And i have tried "ant run-tester"
I find it just call java to run the class.And it's Ok.

I have also tried the "ant test".
It seems that it is based unit test.
But it fails and i then turn off the flag to make it  run regardless of
fail.
I find there are only three testing classes and a few testcases.
Need any configuration to make the unit test success?

And what's the difference between "ant run-tester" and "ant test"? Thanks
again.

BTW, when i run "ant test", it will fail for package missing.
So i add the revelant *jar files from binary into the "javac"'s classpath
parameter.
It works, but of course it is the the right way :) Pls correct me.
I guess maybe it results from the missing of some properties setting.



2006/10/24, Yoav Shapira <yoavs@apache.org>:
>
> Hi,
>
> On 10/22/06, Sean Qiu <sean.xx.qiu@gmail.com> wrote:
> > Required by my project, i have to put  ecj*.jar in ${ant_home}/lib, i
> just
> > rename it to avoid loading it.
>
> OK, but just so you know, that's a terrible requirement by your
> project that will cause you many headaches.  You should really try to
> get your project to correct this.
>
> > Is there any docs to indicate how to test the src???Thanks for your
> help.
>
> From the top-level build file (the one in build/build.xml), run "ant
> clean run-tester"
>
> Yoav
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>


-- 
Sean Qiu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message