tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sean Qiu" <sean.xx....@gmail.com>
Subject Re: [build]fail message
Date Fri, 20 Oct 2006 03:07:55 GMT
I find if run ant more than one time, it will represent "Build Success"
sometimes but failed in fact.
What is the classpath loading sequence?
Ant do have download org.apache.jdt.* in /usr/share/java/eclipse/plugins,
and in my ${eclipse_home}/plugins it contains higher version.
And the build.xml say, 3.1.2 or higher version is Ok.
So i think the seqence won't make any difference.

It is strange that it fails for java.lang.NoSuchMethodError.

Any suggestion?

2006/10/20, Sean Qiu <sean.xx.qiu@gmail.com>:
>
> For the sake of my unstable network status, i could not download the
> required components at first.
> So i had to download them by hand and rename them as required.So it
> failed.
> I set a proxy and it works well. :) Thanks you all.
>
> Now i am confused by the catalina/build.xml
> Do I have to add the build.properties by myself ?
>
> 2006/10/19, Remy Maucherat <remm@apache.org >:
> >
> > Yoav Shapira wrote:
> > > You have the wrong version of the Eclipse JDT jar on your classpath.
> >
> > It may be a good idea to package rename JDT as well (evil grin).
> >
> > Rémy
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> > For additional commands, e-mail: dev-help@tomcat.apache.org
> >
> >
>
>
> --
> Sean Qiu




-- 
Sean Qiu

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message