tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Brittain" <jason.britt...@gmail.com>
Subject Re: Tomcat 5.5.18-beta preview
Date Tue, 29 Aug 2006 20:14:37 GMT
Hi guys.

On 8/29/06, Yoav Shapira <yoavs@cargurus.com> wrote:
>
> Hi,
> We need to clarify the message according to Bill's comments from a
> thread on this list last week.


Clarifying it would be preferable.

The message is still correct for some
> users, especially those using Tomcat 4.1, JDK 1.4, and certain Linux
> kernels.


Here's one data point on it..

Here is the setup that I used to run where I needed the setting:

OS: RH9 i386 with kernel 2.4.20-18.9 (stock RH kernel)
Java: Sun j2sdk1.4.1_03
Tomcat 4.1.30 (official release binary)

Then, later, I needed Java 1.5.x features, so I upgraded it to
Sun Java 1.5.0.  At the time that I upgraded just the JDK, I
knew very well that I have LD_ASSUME_KERNEL set, but I
since I didn't upgrade the OS (same kernel & libs) I left that
setting alone to see if it would cause any ill effects.  That was
a couple of years ago, and it has been working perfectly
ever since.

We should make it clear the message does not apply to all
> situations, should not be standard operating procedure, and should
> only be attempted if you have an older Linux kernel that you can't
> update plus a stability problem that you can't solve otherwise.  Or
> something to that effect...


Yes, that would be excellent.

Thanks.

--
Jason

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message