tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40171] New: - Silent install of tomcat 4.1.32 beta fails on windows
Date Wed, 02 Aug 2006 19:13:16 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40171>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40171

           Summary: Silent install of tomcat 4.1.32 beta fails on windows
           Product: Tomcat 4
           Version: 4.1.32
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: regression
          Priority: P2
         Component: Installable Packages
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: echawkes@hotmail.com


This functionality works in 4.1.29 but is broken in 
4.1.31 and 4.1.32 beta.  I have not tried 4.1.30.  

I found that when I do a clean install of Tomcat 4.1.31 
the installer fails to do a couple of things that 4.1.29 
used to do: 

1) There is no entry for Apache Tomcat in the Windows 
   Control Panel Add or Remove programs list.  

2) There are several files missing from the conf directory 
   C:\Program Files\Apache Group\Tomcat 4.1\conf\
   In fact, the only file that does get installed there 
   is server.xml.  These five files are missing: 

   catalina.policy
   jk2.properties
   server-noexamples.xml.config
   tomcat-users.xml
   web.xml 
 
Since we are installing tomcat as one of several 
3rd party products in our own windows installer, 
we install in silent mode: 
jakarta-tomcat-4.1.31-LE-jdk14.exe /S /D=<our install dir>

I tested by running the tomcat installer from a 
DOS prompt: 
d:\tmp\jakarta-tomcat-4.1.31-LE-jdk14.exe /S 

When I run with the /S option I have both problems. 
When I run the installer with no options, neither 
problem occurs.  

When I install tomcat 4.1.29 
d:\tmp\jakarta-tomcat-4.1.29-LE-jdk14.exe /S 
neither problem occurs. 

I can copy the files over myself if I have to, but I 
don't know how to work around the control panel 
add/remove programs problem.  

I have the Java 2 SDK 1.4.2_12 installed.  
I am testing/developing on Windows XP SP2.  

Note: I tested with 4.1.32 beta as well as 4.1.31.  
The results were the same.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message