tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Hanik - Dev Lists <devli...@hanik.com>
Subject Re: TCK Failed Was: Tomcat 5.5.18-beta preview
Date Tue, 29 Aug 2006 16:55:34 GMT
ok, development=false took care of the three errors, the TCK now runs 
error free for the first run, any subsequent runs I get about 50 or so 
errors.
If I delete the contents of the work directory, it again runs error 
free, I'll do some investigations to see if its an actual issue

Filip


Remy Maucherat wrote:
> Dies Koper wrote:
>> Hello Filip,
>>
>> In my application I used a pageContext.include which once threw a 
>> JasperException (ServletException) while it was supposed to 
>> (according to the spec) propagate the IOException as-is.
>> I noticed that setting the "deployment" init param in conf\web.xml to 
>> "false" made it propagate the IOException correctly.
>>
>> Apparently JspServletWrapper checks this flag and decides to handle 
>> exceptions differently depending on this value.
>> I did not look further into it as my problem is resolved, but I have 
>> been wondering why it would do this and whether to bring it up here.
>
> It's "development". Indeed, it seems to be the reason: the original 
> exception gets wrapped for nicer error reporting purposes. If 
> development mode is off, then the original exception will be passed, 
> so the test should then work.
>
> Rémy
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message