tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39791] New: - very poor default for "Use Naming" when creating new Context
Date Mon, 12 Jun 2006 19:00:37 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39791>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39791

           Summary: very poor default for "Use Naming" when creating new
                    Context
           Product: Tomcat 5
           Version: 5.0.28
          Platform: PC
        OS/Version: Windows Server 2003
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Webapps:Administration
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: clayembry@yahoo.com


When creating a new Context using the Administration webapp, the property
useNaming ("Use Naming" in the HTML form for creating a new context) defaults to
"false". That seems like a poor choice for the default given that it means that
if you create a new Context and a new DataSource using the Admin webapp and you
just accept all the defaults, you will not be able to use the DataSource in your
new Context. Also, the Context Container section in the Server Configuration
Reference says that the default value of the property should be "true".

Symptom:
If you create a Context and DataSource using the Admin webapp and try to use the
DataSource as explained in the How To guide, you will get this exception:
"javax.naming.NameNotFoundException: Name java:comp is not bound in this Context"
Googling seems to show a lot of people having this problem. Not sure how often
it was caused by this issue. It can easily trip up a newbie like me.

To Reproduce:
Create a new Context using the Admin webapp. Do not change any of the default
values for properties. Create a new DataSource in the Context using the Admin
webapp and try to use it in the new Context using code from the How To guide.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message