tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39699] - simple deploy failed in cluster (distributable flag)
Date Fri, 02 Jun 2006 14:25:18 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39699>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39699





------- Additional Comments From cya@nbux.com  2006-06-02 14:25 -------
(In reply to comment #12)
> (In reply to comment #11)
> > 
> > I have 5.5.12 in production with no problems. And yes, 5.5.13 causes the bug to
> > appear for me as well. So, something changed from 5.5.12 -> 5.5.13. Time to look
> > at the changelog for 5.5.13.
> 
> I didn't see anything in the 5.5.13 changelog (with my untrained eye). However,
> this discussion seems to be similar.
> 
>
http://www.nabble.com/RE%3A-Tomcat-5.5.15-Context-Reloading-issue-t1123634.html#a3010048
> 
> Rémy?
> 
> In that thread Rémy says:
> 
>     I added some code to null out certain instances, and your shared log4j
>     setup doesn't like it (at least it's a likely possibility). Try to use
>     a JNDI based log4j setup (or similar, using one logging namespace for
>     all webapps is not clean), or don't share it. 
> 
> Would it be possible to see where is the code which nulls out certain instances??
> 
> The precursor the above thread is at:
> http://www.nabble.com/Tomcat-5.5.15-Context-Reloading-issue-t1076386.html#a2955863
> 
> Be aware that in comment 4 and comment 6, both Christophe and I have reported
> that even with nothing in common/lib (no log4j.jar, no commons-logging.jar), we
> still get the bug. The only log4j.jar and commons-logging.jar is the one present
> in WEB-INF/lib of the webapp. So, more than likely the "shared log4j" setup is
> not the culprit.



in 5.5.12, deploy is ok, but i get this recurrent error in log :
----------------------
 ERROR org.apache.catalina.cluster.tcp.TcpReplicationThread[3]
org.apache.catalina.cluster.tcp.TcpReplicationThread -
 TCP Worker thread in cluster caught 'java.io.IOException: Connection reset by
peer' closing channel
 java.io.IOException: Connection reset by peer
        at sun.nio.ch.FileDispatcher.read0(Native Method)
        at sun.nio.ch.SocketDispatcher.read(Unknown Source)
        at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)
        at sun.nio.ch.IOUtil.read(Unknown Source)
        at sun.nio.ch.SocketChannelImpl.read(Unknown Source)
        at
org.apache.catalina.cluster.tcp.TcpReplicationThread.drainChannel(TcpReplicationThread.java:125)
        at
org.apache.catalina.cluster.tcp.TcpReplicationThread.run(TcpReplicationThread.java:69)
ERROR org.apache.catalina.cluster.tcp.TcpReplicationThread[3]
org.apache.catalina.cluster.tcp.TcpReplicationThread -
TCP Worker thread in cluster caught 'java.io.IOException: Connection reset by
peer' closing channel
 java.io.IOException: Connection reset by peer
        at sun.nio.ch.FileDispatcher.read0(Native Method)
        at sun.nio.ch.SocketDispatcher.read(Unknown Source)
        at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)
        at sun.nio.ch.IOUtil.read(Unknown Source)
        at sun.nio.ch.SocketChannelImpl.read(Unknown Source)
        at
org.apache.catalina.cluster.tcp.TcpReplicationThread.drainChannel(TcpReplicationThread.java:125)
        at
org.apache.catalina.cluster.tcp.TcpReplicationThread.run(TcpReplicationThread.java:69)
--------------------

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message