tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yoav Shapira" <yo...@apache.org>
Subject Re: Deprecation Warnings in ServletRequestWrapper
Date Thu, 18 May 2006 21:21:14 GMT
Hola,
First, I read it as the container must be compile-able under J2SE 1.3,
so maybe we have a different understanding of minimum.

Second, why require something stricter if we don't have to?
Especially now, in what would be the 18th release of Tomcat 5.5,
thereby causing pain those users who do run on JDK 1.3, just to get
rid of some deprecation warnings that don't make any difference to
anyone except you two apparently?

Yoav

On 5/18/06, Joe Hertz <jhertz@speakeasy.net> wrote:
> http://issues.apache.org/bugzilla/show_bug.cgi?id=33104
>
> Closed ostensibly as the spec claims the container must be compilable under JDK 1.3.
>
> I only see this:
>
> J2SE 1.3 is the minimum version of the underlying Java platform with which servlet containers
must be built.
>
> Humor me here. How does "minimum" imply you cant require something stricter? If it did,
and 1.4 deprecated code you used, and 1.5 removed it entirely, wouldn't you be stuck?
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
>
>


-- 
Yoav Shapira
Nimalex LLC
1 Mifflin Place, Suite 310
Cambridge, MA, USA
yoavs@computer.org / www.yoavshapira.com

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message