tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39596] - Connector@address does not work with APR-enhanced Tomcat
Date Thu, 25 May 2006 07:12:43 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39596>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39596


olle@compound.se changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |




------- Additional Comments From olle@compound.se  2006-05-25 07:12 -------
I submitted this errand to users@tomcat.apache.org, but now after two weeks 
nobody have commented on it. Seems like a dead end.

Regarding your tip I tried using address = "::1" which works fine:

INFO main org.apache.coyote.http11.Http11AprProtocol - Initializing Coyote 
HTTP/1.1 on http-0%3A0%3A0%3A0%3A0%3A0%3A0%3A1-80
 INFO main org.apache.catalina.startup.Catalina - Initialization processed in 
1043 ms
 INFO main org.apache.catalina.core.StandardService - Starting service Catalina
 INFO main org.apache.catalina.core.StandardEngine - Starting Servlet Engine: 
Apache Tomcat/5.5.17
 INFO main org.apache.catalina.cluster.tcp.SimpleTcpCluster - Cluster is about 
to start

But when I try to use address = "::127.0.0.1" (which I believe should give the 
same result) this does not work:

ERROR main org.apache.coyote.http11.Http11AprProtocol - Error initializing 
endpoint
 java.lang.Exception: Socket bind failed: [99] Cannot assign requested address
        at org.apache.tomcat.util.net.AprEndpoint.init(AprEndpoint.java:571)
        at org.apache.coyote.http11.Http11AprProtocol.init
(Http11AprProtocol.java:115)
        at org.apache.catalina.connector.Connector.initialize
(Connector.java:1016)
        at org.apache.catalina.core.StandardService.initialize
(StandardService.java:580)
        at org.apache.catalina.core.StandardServer.initialize
(StandardServer.java:791)
        at org.apache.catalina.startup.Catalina.load(Catalina.java:503)
        at org.apache.catalina.startup.Catalina.load(Catalina.java:523)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke
(NativeMethodAccessorImpl.java:39)

Since I cannot use the APR enhancement with a Connector listening to a specific 
IPv4-address, and nobody seems to be able to tell me how it should be done to 
work properly, it looks to me like a bug (or lacking feature) in APR/Connector 
that should be corrected.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message