tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33104] - HttpServerletResponseWrapper deprecation errors with JDK 1.5
Date Thu, 18 May 2006 20:50:49 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33104>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33104


yoavs@computer.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |INVALID




------- Additional Comments From yoavs@computer.org  2006-05-18 20:50 -------
First, Tomcat 5.5 does not require J2SE 5, it works with J2SE 1.4 as well.

Second, Tomcat 5.x as an implementation of the Servlet Spec v2.4 is required to
be compilable under JDK 1.3, which it is, so these methods must be kept in.

With Tomcat 6 it will be a different story, these methods will be removed.

And even if you were right, this would be at best an enhancement request, not a
bug, because they're warnings and not errors.

Finally, please don't reopen this item without discussing it on tomcat-dev
first.  The mailing list is a much better forum for talk and explanations than
Bugzilla.  Thanks.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message