tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39577] - JSPs in subdirectories can't access classes
Date Sun, 14 May 2006 16:17:17 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39577>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39577





------- Additional Comments From mslinn@mslinn.com  2006-05-14 16:17 -------
Discovered the problem, and a workaround.

In server.xml, I had Host appBase="webapps/ROOT" and Context docBase="".  When I
changed the two attributes back to their default values the problem went away.
(appBase="webapps" and docBase="ROOT")

I used the nonstandard values because in another webapp I have three contexts:
 1) webapps/ROOT
 2) webapps/secondContext
 3) webapps/thirdContext

Tomcat 5.5.17 did not like the above, and generated an error message.  I'll post
a separate bug on this issue.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message