tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39179] New: - FarmWarDeployer does not deploy ".war" correctly
Date Sat, 01 Apr 2006 13:23:36 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39179>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39179

           Summary: FarmWarDeployer does not deploy ".war" correctly
           Product: Tomcat 5
           Version: 5.5.12
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Catalina:Cluster
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: timlucia@yahoo.com
                CC: timlucia@yahoo.com


(see also 31978) (Per Filip's request)

The FarmWarDeployer does not correctly deploy a war named (only) ".war".  I get
the following error (Missing application web.xml, using defaults only) in my
tomcat_console.log:

2006-04-01 08:18:05,355 [ContainerBackgroundProcessor[StandardEngine[Catalina]]]
INFO  Diagnostics
: Stopping application 'My Application' at Sat Apr 01 08:18:05 EST 2006
2006-04-01 08:18:05,359 [ContainerBackgroundProcessor[StandardEngine[Catalina]]]
INFO licationLifecycleListener : Application context destroyed. 2006-04-01
08:18:05,381 [ContainerBackgroundProcessor[StandardEngine[Catalina]]] INFO 
ContextConfig
: Missing application web.xml, using defaults only
StandardEngine[Catalina].StandardHost[localhost].StandardContext[/]
2006-04-01 08:18:25,397 [ContainerBackgroundProcessor[StandardEngine[Catalina]]]
INFO  WarWatcher
: check cluster wars at /tmp/war-listen

Note that the previous context running on / was stopped and replaced by this new
one.

OK - Listed applications for virtual host localhost
/admin:running:0:/usr/local/tomcat/server/webapps/admin
/:running:0:
/log4jconfig:running:0:log4jconfig
/:stopped:0:ROOT /manager:running:0:/usr/local/tomcat/server/webapps/manager

If I undeploy the application running as / (from ".war") then the webapp
directory (appBase of the host) IS DELETED!  (Ooops)

Tim Lucia

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message