tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Turner <je...@apache.org>
Subject Re: "Critical poller failure" when using tcnative
Date Mon, 10 Apr 2006 14:03:38 GMT
On Sun, Apr 09, 2006 at 04:27:31PM +0200, Remy Maucherat wrote:
> Jeff Turner wrote:
> >> The error 3 is actually TCN_EINTR - APR_OS_START_USERERR, so
> >> it looks like you actually *did not* patch the AprEndpoint,
> >> or didn't copy the .jars.
> > 
> > Right - I am running an unpatched 5.5.16 at the moment. When I switch to the
> > patched (I assume - I didn't actually do the honours) 5.5.15, the error changes
> > to:
> 
> I just looked at the changelog, and the EINTR status code fix was post 
> 5.5.16 (it will be included in 5.5.17), so at least things are fairly 
> logical :) So you would need to either patch 5.5.16, or use tcnative HEAD.

Thanks Rémy & Mladen, that worked.

FTR, what I did was:
 - svn co http://svn.apache.org/repos/asf/tomcat/current/tc5.5.x
 - cd connectors
 - cp build.properties.default build.properties, and tweak base.path.
 - Ran 'ant download'
 - Ran 'ant dist'
 - cp dist/lib/*.jar $TOMCAT_HOME/server/lib

(the last step was a bit unscientific but it worked).


Cheers,
Jeff

> Rémy
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message