tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andre Kammerl <andre.kamm...@gmail.com>
Subject Re: Building Tomcat
Date Wed, 08 Feb 2006 14:26:03 GMT
The mx4j was the first problem I encountered. The server was broken and the 
search with google didn't show any result. But when I was looking for 
another project for my case study, I found mx4j 1.1.1 on another server. I 
can send you the zip-file if you're interessted. There are four other 
packages that are not available when ant is trying to download them. I only 
remember three of the four names, cause I've downloaded them. The fourth one 
is included in the download of Tomcat 5.5.15, so I only had to copy it. The 
other three are:

saxpath-1.0
jaxen-1.0-FCS
jakarta-struts-1.2.4

Hope this will help you with you patch.

Regards

        André





----- Original Message ----- 
From: "Bob Herrmann" <bob@jadn.com>
To: "Tomcat Developers List" <dev@tomcat.apache.org>
Sent: Wednesday, February 08, 2006 2:44 PM
Subject: Re: Building Tomcat


>
> Thanks! I felt I had it a time or two, but the build script that I use
> (I'm trying to build a pristine copy) downloads stuff from sourceforge and
> kept getting into trouble downloading the mx4j bits.  Seems like they
> dropped the mx4j 2.1.0 and you can only get mx4j 2.1.1 - making a truly
> pristine (ie. md5sum verifyable) version of 5.0 might be very challenging
> in the future if enough bits rot on the vine.
>
> I'm still tinkering with it, should have it working in a few days.   I'm
> planning on posting my patches so they can be used to update the building
> tomcat 5.0 page.
>
> Cheers
> -bob
>
>
>> Hi!
>>
>> Are you still interessted in version 5.0? I've collected all the missing
>> files manually. There is only a problem when ant is trying to build it.
>> Perhaps you can solve it.
>>
>> build-catalina-core:
>>     [javac] Compiling 326 source files to O:\Diplomarbeit\Tomcat
>> 5.0.30\jakarta-
>> tomcat-5.0.30-src\jakarta-tomcat-5\build\classes
>>     [javac] O:\Diplomarbeit\Tomcat
>> 5.0.30\jakarta-tomcat-5.0.30-src\jakarta-tomc
>> at-catalina\catalina\src\share\org\apache\catalina\Container.java:23:
>> cannot
>> acc
>> ess javax.servlet.ServletException
>>     [javac] bad class file: O:\Diplomarbeit\Tomcat
>> 5.0.30\java\servlet-api-2.4\l
>> ib\servlet-api.jar(javax/servlet/ServletException.class)
>>     [javac] class file has wrong version 49.0, should be 48.0
>>     [javac] Please remove or make sure it appears in the correct
>> subdirectory of
>>  the classpath.
>>     [javac] import javax.servlet.ServletException;
>>     [javac]                      ^
>>     [javac] 1 error
>>
>> BUILD FAILED
>> O:\Diplomarbeit\Tomcat 5.0.30\jakarta-tomcat-5.0.30-src\build.xml:50: The
>> follow
>> ing error occurred while executing this line:
>> O:\Diplomarbeit\Tomcat
>> 5.0.30\jakarta-tomcat-5.0.30-src\jakarta-tomcat-5\build.x
>> ml:447: The following error occurred while executing this line:
>> O:\Diplomarbeit\Tomcat
>> 5.0.30\jakarta-tomcat-5.0.30-src\jakarta-tomcat-5\build.x
>> ml:411: The following error occurred while executing this line:
>> O:\Diplomarbeit\Tomcat
>> 5.0.30\jakarta-tomcat-5.0.30-src\jakarta-tomcat-catalina\
>> catalina\build.xml:594: Compile failed; see the compiler error output for
>> detail
>> s.
>>
>>
>> André
>>
>>
>>
>>
>> ----- Original Message -----
>> From: "Bob Herrmann" <bob@jadn.com>
>> To: "Tomcat Developers List" <dev@tomcat.apache.org>
>> Sent: Saturday, February 04, 2006 2:53 AM
>> Subject: Re: Building Tomcat
>>
>>
>>>
>>> Humm.  Since the instructions on the page are broken (cvs and not
>>> subversion, the build.properties.defaults include sites and urls that
>>> are
>>> out of date), perhaps the page should be removed.   Or a disclaimer
>>> should
>>> be added to the page saying that the 5.0 series is not actively
>>> maintained
>>> and that developers should persue the 5.5 line.
>>>
>>> -bob
>>>
>>> Mark Thomas wrote:
>>>
>>>>Bob Herrmann wrote:
>>>>
>>>>>Ok,  Is 5.0 a valid build target, or is its usage discouraged?
>>>>>
>>>>>I was following the build instructions for building tomcat 5.0
>>>>>     http://tomcat.apache.org/tomcat-5.0-doc/building.html
>>>>>the build.xml that it provides use CVS tags to extract the 5.0 bits.
>>>>>
>>>>>-bob
>>>>>
>>>>
>>>>You can build 5.0 if you need to. You'll just need to modify the
>>>>build.xml a bit. If you have the choice, go for 5.5. Very little has
>>>>happened on 5.0 for a while - the focus is on 5.5 and starting 6.0
>>>>
>>>>Mark
>>>>
>>>>
>>>>---------------------------------------------------------------------
>>>>To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
>>>>For additional commands, e-mail: dev-help@tomcat.apache.org
>>>>
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
>>> For additional commands, e-mail: dev-help@tomcat.apache.org
>>>
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
>> For additional commands, e-mail: dev-help@tomcat.apache.org
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
> For additional commands, e-mail: dev-help@tomcat.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message