tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bob Herrmann <...@jadn.com>
Subject Re: Building Tomcat
Date Tue, 31 Jan 2006 19:29:41 GMT
First time building tomcat ( in a while.)   I was following this page,
        http://tomcat.apache.org/tomcat-5.0-doc/building.html

since it recommends ant 1.5, perhaps ant 1.6 has some incompatible 
changes....

This is also in the stack,
    [style] DEPRECATED - xalan processor is deprecated. Use trax instead.
    [style] DEPRECATED - xslp processor is deprecated. Use trax instead.
    [style] java.lang.ClassNotFoundException: 
org.apache.tools.ant.taskdefs.optional.XslpLiaison


I'm focused on 5.0 since 1.4 is what our project runs...  but perhaps 
5.5 with the compatiblity libs would be a better target if I can get it 
building.

Cheers
-bob

Marsh David W Maj AFIT/ENG wrote:

>First time building it, I assume?  I had problems as well.  Hopefully
>this helps.
>______________
>
>Make sure you:
>  download/unzip the source code from
>http://tomcat.apache.org/download-55.cgi 
>     (this'll be in your ${tomcat-source} directory),
>  install Subversion via
>http://subversion.tigris.org/project_packages.html, 
>  and follow the directions at
>http://tomcat.apache.org/tomcat-5.5-doc/building.html,
>
>Also the ant build may fail when it gets to jasper because the unzipped
>code puts the necessary files in the .../jasper/jasper2 directory.  Move
>the code up a directory or change the ant script at line 1419 of
>${tomcat.source}/build/build.xml from
>
>1418    <!-- tomcat jasper source -->
>1419    <copy todir="${tomcat.dist}/src/${jasper.project}">
>
>to
>
>1418    <!-- tomcat jasper source -->
>1419    <copy todir="${tomcat.dist}/src/${jasper.project}/jasper2">
>
>I don't know the implications of this change versus moving the files.
>
>David
>-----Original Message-----
>From: Bob Herrmann [mailto:bob@jadn.com] 
>Sent: Tuesday, January 31, 2006 2:08 PM
>To: dev@tomcat.apache.org
>Subject: Building Tomcat
>
>Hi!  I just tried to compile Tomcat on my Fedora 4 box w/o happiness.  
>(using the network download build.xml, jdk1.4_09 and tried jdk5)
>
>$ ant
>...
>BUILD FAILED
>/home/bob/Desktop/t2/build.xml:50: The following error occurred while
>executing this line:
>/home/bob/Desktop/t2/jakarta-tomcat-5/build.xml:796: The following error
>occurred while executing this line:
>/home/bob/Desktop/t2/jakarta-tomcat-catalina/webapps/docs/build.xml:84: 
>java.lang.ClassNotFoundException: 
>org.apache.tools.ant.taskdefs.optional.TraXLiaison
>
>Before I start digging more, does this ring bells?
>
>
>Thanks!
>-bob
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org For additional
>commands, e-mail: dev-help@tomcat.apache.org
>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
>For additional commands, e-mail: dev-help@tomcat.apache.org
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message