tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 37977] New: - adapt build/BUILDING.txt and build.xml for svn on windows
Date Tue, 20 Dec 2005 13:56:16 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=37977>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=37977

           Summary: adapt build/BUILDING.txt and build.xml for svn on
                    windows
           Product: Tomcat 5
           Version: 5.5.9
          Platform: Other
               URL: http://tomcat.apache.org/tomcat-5.5-doc/build.xml
        OS/Version: other
            Status: NEW
          Severity: enhancement
          Priority: P2
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: hauser@acm.org


Tried to rebuild tomcat according to BUILDING.txt 

<<RalfCHauser@RalfHauser:~/<2>tomcat/mybuild> ant
Buildfile: build.xml

check.source:

get.source:

checkout:
     [echo] If the checkout fails, - todo -

BUILD FAILED
C:\Documents and Settings\RalfCHauser\My
Documents\psph\workspace\tomcat\mybuild\build.xml:87: The following error occur
red while executing this line:
C:\Documents and Settings\RalfCHauser\My
Documents\psph\workspace\tomcat\mybuild\build.xml:70: Execute failed: java.io.I
OException: CreateProcess: svn checkout
http://svn.apache.org/repos/asf//tomcat/current/tc5.5.x C:\Documents and Setting
s\RalfCHauser\My Documents\psph\workspace\tomcat\mybuild error=2

Total time: 0 seconds>>

1) I guess it would be good to update the BUILDING.txt to reflect the move from
CVS to SVN since it still mentions CVS.
2) I do not know a command-line svn client for windows since I use Tortoise as
per http://www.apache.org/dev/version-control.html#anon-svn

I did download the "subversion" package in cygwin and got a little bit further
<<RalfCHauser@RalfHauser:~/<2>tomcat/mybuild> ant
Buildfile: build.xml

check.source:

get.source:

checkout:
     [echo] If the checkout fails, - todo -
     [exec] svn: Can't make directory
'Documents\psph\workspace\tomcat\mybuild/tc5.5.x': No such file or directory
     [exec] Result: 1

build:

BUILD FAILED
C:\Documents and Settings\RalfCHauser\My
Documents\psph\workspace\tomcat\mybuild\build.xml:48: Basedir C:\Documents and
Settings\RalfCHauser\My Documents\psph\workspace\tomcat\mybuild\build does not exist

Total time: 39 seconds
RalfCHauser@RalfHauser:~/<2>tomcat/mybuild>
>>

So, it appears that either the build.xml should be made cygwin aware i.e.
3) a `cygpath -u ${basedir}` might help here or
4) <exec dir="${basedir}" executable="svn">
         <arg line="checkout ${svnroot}/${current.loc} ${basedir}" />
    </exec>
could be changed to 
<exec dir="${basedir}" executable="svn">
         <arg line="checkout ${svnroot}/${current.loc} . " />
    </exec>

At least, with cygwin's command line "svn checkout
http://svn.apache.org/repos/asf/tomcat/current/tc5.5.x ." it worked nicely
afterwards

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message