tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 36153] - html:form action is blank
Date Mon, 14 Nov 2005 08:44:09 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=36153>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=36153





------- Additional Comments From tcurran@approachingpi.com  2005-11-14 09:44 -------
I was having this same problem and couldn't figure out why.  I was using jdk
1.5, tomcat 5.5.9, struts 1.2.7 and everything looked fine.

I don't know if this is the issue Matt was having, but here is how I fixed it
for me.

After reading through the struts source, I found that
org.apache.struts.taglib.TagUtils assumes that you have a single servlet mapping
to struts (in getActionMappingURL), I infact had three in order to get a few
urls to work without whatever.do:

    <servlet-mapping>
        <servlet-name>action</servlet-name>
        <url-pattern>*.do</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
        <servlet-name>action</servlet-name>
        <url-pattern>/campaigns</url-pattern>
    </servlet-mapping>
    <servlet-mapping>
        <servlet-name>action</servlet-name>
        <url-pattern>/publishers</url-pattern>
    </servlet-mapping>

to get my forms working again.  All I had to do was move the *.do mapping to the
bottom of the list of three mappings.


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@tomcat.apache.org
For additional commands, e-mail: dev-help@tomcat.apache.org


Mime
View raw message