tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Costin Manolache <cmanola...@yahoo.com>
Subject Re: How strongly Tomcat 5.5.x will be committed to JDK 1.4.x in future..
Date Thu, 15 Sep 2005 05:54:22 GMT
The current servlet spec doesn't requires J2SE 5.0 - only the next one ( 
another stupid forced, unjustified transition IMO ).

I would assume JDK1.4 will be supported for a while, as long as the 
current version of the servlet spec is in use.
Tomcat3.3, which supports JDK1.1, has been maintained for quite a while 
after switching to JDK1.3 and then JDK1.4. I don't see how anyone who 
has been around for past upgrades could expect a mass migration to the 
new servlet spec and JDK1.5.


Costin

Yoav Shapira wrote:
> Hi,
> Tomcat 5.5 will always allow JDK 1.4.  Tomcat 6.0, as required by the J2EE 5
> specifications, will require J2SE 5.0.  I repeat, for emphasis, that this is
> required by the J2EE 5 Specification itself, which Tomcat 6.0 will support: it
> is not our decision to drop support for JDK 1.4.
> 
> Yoav
> 
> --- Girish Vasvani <girish_vasvani@yahoo.com> wrote:
> 
> 
>>Hi,
>> 
>>We'r puzzled between tomcat 5.0.x and 5.5.x.
>>Due to our product restrictions we can't use JDK 1.5. Looked at jakarta web
>>site, it seems that using tomcat 5.5.x seriese compated to 5.0.x is a good
>>idea and recommended.
>> 
>>Before committing our product to tomcat 5.5.9, I want to know how much tomcat
>>dev team will be committed to supporting JDK 1.4.x going forward ? 
>> 
>>thanks in advance for your help,
>>Girish
>> 
>>
>>		
>>---------------------------------
>>Yahoo! for Good
>> Click here to donate to the Hurricane Katrina relief effort. 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message