tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Moy <geek....@gmail.com>
Subject 5.0.28 chunked input?
Date Fri, 16 Sep 2005 22:51:14 GMT
I am running standalone Tomcat 5.0.28, and am having problems with
chunked requests.

My servlet is being called before a chunked POST has completed the
transfer of its body containing x-www-form-urlencoded data.  My
servlet calls to getParameter() return empty values, because the chunk
containing the data has not arrived yet.  I expected the chunked data
to be processed before I am called, is this an incorrect assumption?

I am watching the exchange in Ethereal and see that the chunk does
eventually arrive, but I have already completed my servlet processing
by that time.  I've attached the TCP trace (with proprietary paths
fixed up), thanks to anyone who can shed light on this problem.  Note
that my servlet is generating the XML response.

Thanks for any help,

Jim Moy

----
POST /site/path/ HTTP/1.1
Content-Type: application/x-www-form-urlencoded
Accept: */*
User-Agent: UNTRUSTED/1.0
Host: myhost.net
Transfer-Encoding: chunked

HTTP/1.1 200 OK
Content-Type: text/plain;charset=ISO-8859-1
Content-Length: 77
Date: Thu, 15 Sep 2005 15:18:07 GMT
Server: Apache-Coyote/1.1

<?xml version="1.0"?>
<mydata>
 <status>mystatus</status>
</mydata>

18
data1=value1&data2=value2
0

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message