tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antti Rauramo <>
Subject Re: Tomcat 5.5.9, endorsed jars and classloader
Date Thu, 01 Sep 2005 10:52:58 GMT
Yoav Shapira wrote:

>>With older tomcats this has been works fine for years now, but with 
>>5.5.9 an IllegalAccessException is thrown.
>Which older Tomcats?  Specifically, does it work in 5.0.28 or 5.5.7?  4.x and
>5.x tell a bit of a different story when it comes to classloading
The "older" is 4.1.31.

>>The server with Tomcat 4.1.31 runs Sun's JDK 1.5.0-b64, the one with 
>>Tomcat 5.5.9 runs Sun's JDK 1.5.0_04-b05. It is possible for me to 
>>upgrade the other if you think this may be an issue. The classloaders 
>>toString() output is actually different, come to think of it...
>It would be good to make them use the same JVM version, if only to rule out
>that variable.  But better yet, please test 5.0.28 and 5.5.7.
Tomcat 5.0.16 and Sun's JDK 1.4.2_02: valid classloader for A, null for B.

Sorry, for now I try to use the Tomcat's that I already have 
installed... But this seems to rule out the JVM version, and pinpoint 
the change to have happened between 4.x and 5.0.x.

Antti Rauramo
Index Information Technologies Oy

View raw message