tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <r...@apache.org>
Subject Re: APR AJP Connector loosing data
Date Thu, 28 Jul 2005 12:25:28 GMT
Mauricio Nuñez wrote:
> El jue, 28-07-2005 a las 01:09 +0200, Remy Maucherat escribió:
> 
>>Mauricio Nuñez wrote:
>>
>>>Apparently , my report was useful! :-)
>>
>>The issue turned out to be really basic. Any other problems besides that ?
>>
>>Rémy
>>
> 
> 
> Thanks. 
> 
> I'm begining to recompile the CVS connector to try. Now I'm fighting
> with  "the jakarta jar hell" :-) . 

There's no hell involved ... There's one source file involved (actually, 
only one line). What you need to do is javac that one class (which only 
depends only on JARs which are in the Tomcat bundle in server/lib: 
tomcat-apr, tomcat-util, tomcat-coyote, tomcat-ajp). Even getting the 
full thing is easy as long as you know Ant (ant download; ant).

> Now I'm testing the NIO connector. 
> After the compilation, I'will send you my results. 
> 
>  
> Well, for the log, the test case about the APR AJP loosing data is to
> configure apache2 + mod_jk + Tomcat woth Apr AJP13 socket, and try any
> page with size > 8192. Tested with Linux Centos 4, Sun JDK 1.5.0_03.

I noticed that after trying random stuff. While it's good to send 
details, it's less useful to send them after the bug has been fixed.

Rémy

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message