tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 35497] New: - tomcat5 stops responding to requests, leaves zombie processes, no response to TERM signal
Date Fri, 24 Jun 2005 13:45:12 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=35497>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=35497

           Summary: tomcat5 stops responding to requests, leaves zombie
                    processes, no response to TERM signal
           Product: Tomcat 5
           Version: 5.5.9
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: Unknown
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: kenny.pearce@hxti.com


Installation details: Tomcat standalone servlet container (standard installation
from source)
jdk1.5.0_03
Red Hat Enterprise Linux 3

Additional JARs in shared/lib: Sun AppServer SAAJ implementation (saaj-api.jar,
saaj-impl.jar)
JSP standard taglib
JavaMail

Server Use Pattern: development platform for a handful of programmers working on
servlets simultaneously. Lots of undeploying and redeploying of applications as
they change and need to be tested. 

Tomcat Invocation: started via the script included in
bin/jsvc-src/native/Tomcat5.sh, slightly modified to support the "restart"
command and installed in /etc/init.d/tomcat. 

Configuration: standard (nothing changed except hostname to IP on local network,
port from 8080 to 80, etc.)

Behavior: Twice now in the period of a week Tomcat has spontaneously stopped
responding to requests (doesn't reject them, just times out). Servlet threads
running in the background also stop. This includes the Tomcat test servlets, not
just the servlets we are developing. Subsequently, the jsvc processes (there are
two; one runs as uid root, the other as uid tomcat5, not sure why) do not
respond to the TERM signal. They must be killed with the KILL signal and
restarted before any server content (including static HTML) can be accessed. I
doubt if this is of any significance, but I think it is strange that it has
happened at almost exactly the same time of day in both cases (~16:30, system
time). The behavior is sporadic and I have as yet been unable to produce it at
will, but am working on it.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message