tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Brittain <ja...@brittainweb.org>
Subject Tomcat 5.5.9 runs on Kaffe 1.1.5 (was Re: Tomcat and APR)
Date Thu, 28 Apr 2005 16:50:14 GMT
Jason Brittain wrote:
> Remy Maucherat wrote:
> 
>> Jason Brittain wrote:
>>
>>>> "This release of Apache Tomcat was packaged to run on J2SE 5.0
>>>> or later. It can be run on earlier JVMs by downloading and
>>>> installing a compatibility package from the Apache Tomcat
>>>> binary download page."
>>>> means JMX wasn't found, that's all.

Okay, I confirmed at least one way to make Tomcat 5.5.9 run on Kaffe 1.1.5.
Adding the jmx.jar to the Kaffe's boot classpath works:

# export CATALINA_BASE=/home/$USER/jakarta-tomcat-5.5.9
# export CATALINA_OPTS="-Xbootclasspath/p:$CATALINA_BASE/bin/jmx.jar"
# cd $CATALINA_BASE
# bin/catalina.sh start

Now, Tomcat runs.  I tried the JSP examples, and they work.  I'll see
about benchmarking it versus JDK 1.4.x and 1.5.x.  :)

Thanks for the help Remy.

-- 
Jason Brittain

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message