tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33385] New: - Tags are duplicating the generated HTML
Date Thu, 03 Feb 2005 11:23:21 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33385>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33385

           Summary: Tags are duplicating the generated HTML
           Product: Tomcat 5
           Version: 5.5.4
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: critical
          Priority: P1
         Component: Jasper
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: saurabh.kumar@siemens.com


I am having a JSP which is composed of three tags.
When I access my JSP for the first time after starting my tomcat(5.5.4),the 
JSP generates(and hence the browser displsys :-)) the HTML properly.
However,after resubmitting the JSP,the HTML generated by one of my tags gets 
duplicated and the whole HTML is doubled in output( e.g one pair of <TR> and 
<TD> is shown as two pairs of <TR> and <TD>.).If keep reftreshing/resubmitting

my JSP,the HTML output just keeps on multiplying !!!
However,when I replace the jar files 1)jasper-compiler.jar and 2)jasper-
runtime.jar present in the "D:\Program Files\jakarta-tomcat-5.5.4\common\lib" 
directory with the older versions of these files from Tomcat version 4.0.1 and 
remove the jar file "jasper-compiler-jdt.jar",then the problem gets resolved.
Also,if I clear the Tomcat's "work" direcroy for my web application,then the 
JSP gives proper output on the first hit but the problem starts after second 
and subsequent hits.

I am ensuring from my side that there is no problem with my Tags or my JSP 
since that used to work in earlier versions of Tomcat(and still working with 
new Tomcat5.5.4 after changing the jasper jar files as explained above).

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message