tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33373] - jspc precompiling jsp with absolute uri in taglib fails
Date Thu, 03 Feb 2005 00:21:33 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33373>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33373





------- Additional Comments From lists@codebarn.com  2005-02-03 01:21 -------
there were changes to o.a.jasper.jspc.java concerning the classloader.  i can't 
demonstrate this in a ready to run war since the problem doesn't happen if i 
let jsp's compile at runtime.  this is only happening to me at precompile 
time.  i did some more testing and have narrowed the behavior down to a case 
where if i have 2 .jsp files named a.jsp and b.jsp and the second one 
alphabetically (b.jsp) has the taglib reference but a.jsp doesn't, then the bug 
happens.  if i rename a.jsp to c.jsp so that the non taglib jsp comes after the 
taglib one, then it works.  it appears that something magic is happening so 
that precompiling with taglibs only works if the first jsp that is processed by 
jspc.java contains a taglib reference.  if you diff jspc.java between 5.5.4 and 
5.5.7 you'll see a number of changes regarding its management of the 
classloader that may or may not be the culprit.  hope this is of some help :)

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message