tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <r...@apache.org>
Subject Re: [Q] TC 5.5.x/TC 5.0.x
Date Mon, 03 Jan 2005 15:51:31 GMT
Stephane Bailliez wrote:
> 
> Could you guys clarify a bit the development effort on TC 5 ?
> (Note: i'm asking the question since I was unable to find such info on 
> the ml archive despite the TC5.5 thread many moons ago)
> 
> I'd appreciate to know what I can recommend as a Servlet 2.4/ JSP 2.0 
> production ready container.
> 
> AFAIK development effort is focused on 5.5.x and some stuff backported 
> in 5.0.x. Until what point is it reasonable to expect something on the 
> 5.0.x branch ? Did you agree on a pseudo milestone to drop support ?

Branches are supported as long as there are people willing to do the 
work. 3.3 is still supported, for example.

> 5.5.x uses JRE 5.0 which may or may not be appropriate for many 
> organizations, so 5.0.x remains an in-between alternative for many 
> environments, but I'd like your developer opinion on the status of each 
>  branch as of today.

5.5 does not require Java 5. The default binary is packaged for Java 5, 
and there's a compatibility package adding a few JARs for Java 1.4.

Rémy

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message