tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 33095] - Symbolic links in webapp not working as expected
Date Fri, 14 Jan 2005 14:59:17 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=33095>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=33095


balbir.sanghera@ntlworld.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|INVALID                     |




------- Additional Comments From balbir.sanghera@ntlworld.com  2005-01-14 15:59 -------
Ok then,  why should a symbolic link in a directory cause the container to throw
exception??, that's why I raised a bug.

The web app directory is:

ROOT/
    | filea
    | fileb
    | tmp1/
         | filef -> ../filea
    | 
    | tmp2/
         | dirc -> /opt/test/somedir


1.  While I open the browser at "/" I get a directory listing
2.  When I move the browser into tmp or tmp2 I get an exception (weather
I have allowLinking enabled/disabled)

bal.




       


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message