tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32495] New: - Filter is not executing in authentication form login page
Date Thu, 02 Dec 2004 15:25:14 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32495>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32495

           Summary: Filter is not executing in authentication form login
                    page
           Product: Tomcat 5
           Version: 5.0.28
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: critical
          Priority: P2
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: afedoren@yahoo.com


About to use filter with url-pattern "/*" .


When to point browser to web resource that is constrained by 'role-name'
in web.xml , Catalina forwards to form-login-page defined in <login-config>.

In the moment, filter is not executed and I have LOGIN page broken due to
missing filter's invoking .

Also, filter is not executing when I try to login and enter invalid
username/password .


Filter begins to work ONLY after succesfull authentication .


Why does not filter execute in above cases ?

Is it the really right/good behaviour ?

Thank you.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message