tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brij Naald" <brijna...@hotmail.com>
Subject Starting tomcat inside eclipse
Date Fri, 26 Nov 2004 14:29:11 GMT
Hi, i'm trying to start tomcat within eclipse, to make debugging somewhat 
easier.
I followed the orders on the tomcat webpage, but it doesn't work.
I took org.apache.catalina.startup.Catalina as main class,
put start at the program arguments, and I put
-Dcatalina-home="D:\tomcat\jakarta-tomcat-5\build" as the VM argument.

I then gives following exception (it has something to do with the catalina 
home. What have I done wrong? (I already tried it without the ", and I 
already tried to change the \ in /.

Thanks for the help!

java.lang.NullPointerException
	at java.util.Hashtable.put(Hashtable.java:393)
	at java.util.Properties.setProperty(Properties.java:102)
	at java.lang.System.setProperty(System.java:656)
	at org.apache.catalina.startup.Embedded.initDirs(Embedded.java:916)
	at org.apache.catalina.startup.Catalina.setCatalinaHome(Catalina.java:425)
	at org.apache.catalina.startup.Catalina.process(Catalina.java:178)
	at org.apache.catalina.startup.Catalina.main(Catalina.java:166)
Exception in thread "main"

_________________________________________________________________
Kies nu de Site Van Het Jaar en win prachtige prijzen! 
http://www.sitevanhetjaar.be/


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message