tomcat-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 32135] New: - AccessLogValve directory attribute ignores leading slash
Date Tue, 09 Nov 2004 22:23:06 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG 
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=32135>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND 
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=32135

AccessLogValve directory attribute ignores leading slash

           Summary: AccessLogValve directory attribute ignores leading slash
           Product: Tomcat 5
           Version: 5.0.27
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: Normal
          Priority: Other
         Component: Catalina
        AssignedTo: tomcat-dev@jakarta.apache.org
        ReportedBy: sam@redspr.com


The configuration directive:
<Valve className="org.apache.catalina.valves.AccessLogValve"
directory="/var/www" ...

Will log in '/var/www' on Unix but '$TOMCAT_HOME/var/www' on Win32. 

Im note sure what the ideal behaviour is but as now it seems 
inconsistent. My vote would be for the configuration files to use
Unix style path/seperator.

Thanks

Sam

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-dev-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-dev-help@jakarta.apache.org


Mime
View raw message